Internet Control Message Protocol

IPv4 protocol for network error reporting and diagnostics
rdfs:label
"Internet Control Message Protocol"@en
skos:altLabel
"ICMP"@en
"ICMPv4"@en
schema:description
"IPv4 protocol for network error reporting and diagnostics"@en
schema:dateModified "2026-11-06T21:35:14+00:00"^^xsd:dateTime
schema:version 2565606671
wikibase:identifiers 14
wikibase:sitelinks 48
wikibase:statements 33
p:P10283 wd:statement/Q13162-157A8EB5-8BD9-4913-A506-85CF2F5D1D7D
p:P10376 wd:statement/Q13162-c0de172a-4e50-a7f1-7bf8-d0da4239249f
p:P10565 wd:statement/Q13162-94B9804B-B8F0-4A51-9209-9BA88A8742AA
p:P12946 wd:statement/Q13162-D86450D6-13C4-437B-9904-F8A3B7A16AA4
wd:statement/Q13162-FECC08F5-A32A-4DA2-B54E-5160A3A3E5BE
p:P1343 wd:statement/Q13162-0b987126-4c7b-679a-6b0c-9d06f53cd099
wd:statement/Q13162-7774a69b-457e-ff8e-7c20-8cc71e3b6c45
wd:statement/Q13162-801d633a-4413-cb56-37d7-35cf90d853af
wd:statement/Q13162-8a7e9950-491a-f912-1bef-842ac7a0d84e
wd:statement/Q13162-9a2d04fe-4a02-cf54-1f6e-4e3220770189
wd:statement/Q13162-9b01ce40-47c9-2adc-f33d-a137e1d61a59
wd:statement/Q13162-dc3e43c8-440d-9d35-6854-1cbb214652b9
p:P14367 wd:statement/Q13162-43531066-F398-49F2-91E8-78FC84E9549F
p:P14541 wd:statement/Q13162-2038C3DB-4CAC-4F70-9B7D-8D4EE2C0AEBE
p:P1535 wd:statement/Q13162-064d4404-4690-b91c-9911-4db5d4240ea0
wd:statement/Q13162-3d0b7c4d-488c-48d7-f2bc-5fa95d27aafd
wd:statement/Q13162-de6c260c-49b7-deb9-aaf7-345a1051caec
p:P156 wd:statement/q13162-67b5c64e-4b23-f61c-83fe-e3eace829d42
p:P1641 wd:statement/Q13162-50d88bd3-494e-bd2d-4438-824bef3be689
p:P18 wd:statement/Q13162-8f51af7b-4e0f-983f-4251-21edd0b978d6
wd:statement/Q13162-cd9e1e36-42b5-fc1d-908f-7472af04d547
p:P227 wd:statement/Q13162-f58e39cf-4dbb-e699-31a1-940e2a789f25
p:P2347 wd:statement/Q13162-6DF38238-2E4C-47E7-873B-34AC52E0EF31
p:P31 wd:statement/Q13162-ef53a395-449d-57f7-6a74-8e0b28032a5e
p:P3417 wd:statement/Q13162-28DE6586-9178-4ECF-9DBF-3FA350245299
p:P361 wd:statement/Q13162-b2552f7b-4a82-6b81-cfdf-5ab5ed7935a6
p:P373 wd:statement/Q13162-66c5d3a4-4909-5c52-5846-06350993f3b5
p:P3743 wd:statement/Q13162-47edd546-43b9-b059-9c04-5d29c986267d
p:P571 wd:statement/Q13162-4ee40673-4a55-1955-1319-68bc4cd36f38
p:P5805 wd:statement/Q13162-f9a98f85-4582-af23-29e4-5555202414f4
p:P6366 wd:statement/Q13162-1060171A-8403-42DA-9A31-B8BD757F79E7
p:P646 wd:statement/Q13162-99B92C71-3434-47C3-B829-21C31DCEA343
p:P8408 wd:statement/Q13162-A801C912-4CA8-4920-8AC8-A874A0D9A220
p:direct-normalized/P227 <https://d-nb.info/gnd/4585818-4>
p:direct-normalized/P2347 <http://www.yso.fi/onto/yso/p14439>
p:direct-normalized/P6366 <https://makg.org/entity/195219913>
p:direct-normalized/P8408 <http://kbpedia.org/kko/rc/InternetControlMessageProtocol>
wdt:P10283 "C195219913"
wdt:P10376 "computer-science/internet-control-message-protocol"
wdt:P10565 "31533"
wdt:P12946 "Internet+Control+Message+Protocol"
wdt:P1343 RFC 2521: ICMP Security Failures Messages
RFC 6918: Formally Deprecating Some ICMPv4 Message Types
RFC 1788: ICMP Domain Name Messages
RFC 4884: Extended ICMP to Support Multi-Part Messages
RFC 792: Internet Control Message Protocol
RFC 6633: Deprecation of ICMP Source Quench Messages
RFC 777: Internet Control Message Protocol
wdt:P14367 "2979"
wdt:P14541 "BjVxr"
wdt:P1535 networking hardware
Ping
traceroute
wdt:P156 ICMPv6
wdt:P1641 1.0^^xsd:decimal
wdt:P18 <http://commons.wikimedia.org/wiki/Special:FilePath/ICMP%20header%20-%20General-ar.svg>
<http://commons.wikimedia.org/wiki/Special:FilePath/ICMP%20header%20-%20General-en.svg>
wdt:P227 "4585818-4"
wdt:P2347 "14439"
wdt:P31 computer network protocol
wdt:P3417 "Internet-Control-Message-Protocol"
wdt:P361 Internet protocol suite
wdt:P373 "ICMPv4"
wdt:P3743 "1.3.6.1.2.1.5"
wdt:P571 "1981-01-01T00:00:00+00:00"^^xsd:dateTime
wdt:P5805 network layer
wdt:P6366 "195219913"
wdt:P646 "/m/03x4l"
wdt:P8408 "InternetControlMessageProtocol"
Download as:
TurtleJSON-LDRDF/XML
data from SPARQL profile: Wikidata